专注于Magento开发与外贸SEO推广
Magento主题|Magento插件|Magento教程

Bash . configure permission denied错误

当你在Linux(我这里是Ubuntu10.04LTS Desktop)下编译安装某个包的时候,你首先是进入到解压目录然后执行“$ ./configure”的,但是有时候你会发现提示错误,错误提示是这样的:
$ ./configure
bash: ./configure:权限不够?????? [英文状态下提示的是“bash . /configure permissiondenied”]
如果你改为执行
$ bash ./configure
那么就没有这个问题了,那为什么会出现这个问题呢?那是因为那个configure文件非可执行文件的原因,当你在当前目录下执行
$ chmod +x ./configure
即为当前目录下的configure文件添加可执行性之后你就可以通过直接
$ ./configure
的方式来安装了。也就是说解决这个错误的办法是先执行
$ chmod +x ./configure
亦或者你加个“bash”即:
$ bash ./configure
亦可。

未经允许不得转载:Magento|Magento2|magento开发|magento插件|magento主题|magento模板|magento商城|magento维护 » Bash . configure permission denied错误
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

Magento开发|Magento咨询QQ283475615

联系我们